Building with the dmengine android app doesn’t work anymore (1.2.132)

#1

Dmengine was working good until I got the Defold update 1.2.132.
Now it makes this during a few minutes until I get an error message :

Both Defold and dmengine are at 1.2.132 there is no version problem, I never had this problem before, the last time I used dmengine was before the update, and I tried to shut down my antivirus.

1 Like

#2

If you bundle the app for Win32 (don’t check the “release” box), then run the app from the command prompt, what does it say then in the console? What happens?

1 Like

#3

This happens (Candy Farm is the app name) and then nothing

1 Like

#4

I’m not very familiar with the start command, but I interpret that as you created a new command prompt, with the window name of “Candy Farm”?

What if you instead just write “Ca” and then tab (autocomplete) so that it spells out the executable name, to something like this, and then press enter:

...\Candy Farm>Candy/ Farm.exe
1 Like

#5

I tried with PoweShell instead, and everything works fine

I have other recent issues that are maybe linked, when I bundle my android app and try it on my android device I experience bugs that are completely absent from the editor build. I have one gui node not responding to the input and a feature that completly disapeared whereas it works perfectly in the editor build.
Those are not related to a problem with saves or anything, I mean, the only explaination I can make is that some code lines are deleted during the process of bundling, always the same (and it’s too crazy to be believable)
And those bugs are also absent from the Win32 build.

1 Like

#6

How do you detect the input? I’m thinking the Win32 and Android builds have different resolutions, so that might play a part in it?

1 Like

#7

Are you using the default renderscript or a custom one?

2 Likes

#8

Two quick questions:

2 Likes

#9

Yes, same behavior for new empty projects and all my current projects.

Yes dmengine work with older 1.2.131, despite it is dmengine 1.2.132.

So as I could use dmengine on this project thanks to the older version @sven linked me I fixed those bugs ! In fact the nodes were triggerd twice instantly because I made this to not always use dmengine when it was working (because it is slower to build with)

if (action_id == hash("click") or action_id == hash("multi_touch")) and action.pressed then

So every click on windows was triggering only the “click” action (mouse action left button) but every touch on android was triggering once the “multi_touch” and the “click” action

I don’t use cutom render it is the builtins/render/default.render

0 Likes

#10

To be clear: Bundling and running with 1.2.132 worked?

0 Likes

#11

Building and running without dmengine in Defold 1.2.132 always worked
Building and running with dmengine in Defold 1.2.132 never works with any project, empty or not
Building and running with dmengine ( that is 1.2.132) in Defold 1.2.131 worked
Sorry if I still don’t get it sometimes my english is getting challenged :zipper_mouth_face:

0 Likes

#12

Can you explain more what this means exactly? dmengine is the engine binary and is always used.

Do you mean hitting Ctrl+B in the editor? Or doing Project->Bundle?

0 Likes

#13

Oh, that’s clearer now, since the beginning I was speaking about the android app dmengine used to test applications directly on the android device via Wi-Fi I am so sorry !
So Ctrl+B targeting “local engine” works but targeting my android device with the dmengine app makes the result I shown in my first screenshot.

2 Likes

#14

Aha I see, makes it a bit clearer. :slight_smile:

Could it be that the Wifi is slow? Did you recently add any large resources? Do you get any other error/popup except the log you showed in the first screenshot?

Perhaps the app goes into “sleep” before all the content have been loaded?

0 Likes

#15

Slow Wi-Fi or heavy resources or even app “sleep” is not possible since I can make it with Defold 1.2.131 and I got no problem with it. I tried a lot of times with both versions of Defold, and for good, I can use dmengine android app (version 1.2.132) with Defold 1.2.131 and not with Defold 1.2.132.
No error popup shown exept when the timeout is reached, the build process just stops on “Rebooted [device name][wi-fi ip][wi-fi port]”

To me the most probable issue is that there is something wrong with 1.2.132 and Meizu devices or Flyme OS, this is the only thing I can’t test because I own only one smartphone :confused:

0 Likes

#16

I just got the 1.2.133 update and the problem persists

0 Likes

#17

I’m using version 1.2.167 and this issue is effecting me aswell.

0 Likes

#18

Which issue exactly?

0 Likes

#19

where it freezes on the first line of INFO:ENGINE: Defold Engine 1.2.167 (hash) and says rebooted in the bottom left.

0 Likes

#20

I need more information to help you. Can you please provide the information requested here.

1 Like