Bugs in Defold 1.2.125 (UPD : Not only in 125)(SOLVED)

#3

Of course

  1. Very fast time in game(instead 60 fps I see more greater). In New Projects too
  2. Problem with button “Build” from Project(did nothing), but if do it in New Project from Tutorial - all good
  3. Can’t open all from “View”(Show Console, Show Curve Editor and other). But when project was opened I saw Console, but in one second it was hide by himself. This not working at all projects.
  4. Bundle for Windows too create nothing. But from New Project Tutorial good too.
0 Likes

#4

How are you moving your game objects? go.animate(), update(), physics?

Do you get an error in the console when trying to build your project? Any native extensions?

Is the bar with the Console, Curve Editor etc gone or simply non responsive?

Same as #2. Any errors in the console? Any native extensions?

1 Like

#5

Only update, and I don’t touch default value tick per seconds, and I told that in New Projects too.

I can’t see Console, Button like in 3 did nothing, I click -> Nothing

Simple non responsive

Same as #2. I can’t see this :smiley:

0 Likes

#6

Which OS are you using? Could you try a fresh install of Editor 2 and check if that makes any difference?

And you take dt into account when moving your game objects?

0 Likes

#7

I use Windows 10. I already use Editor 2, and I try reinstall this(yes, delete folder and paste new folder)

Yes, when I did tutorial I met this, but don’t given it much value, I simple changes speed from 200 to 15 for example.

0 Likes

#8

Did you by chance upgrade or change you graphics drivers recently? By the way you describe it it sounds like the driver vsync settings have changed.

0 Likes

#9

[EDIT:]

Try downloading a previous version and see if the problem goes away.

0 Likes

#10

Sorry, afraid that chance = 0.01
May be I can give some logs?

0 Likes

#11

Not sure I understand what you’re saying. Are you multiplying by dt or not when moving?

go.set_position(go.get_position() + vmath.vector3(200, 0, 0))

or

go.set_position(go.get_position() + vmath.vector3(200, 0, 0) * dt)

?

0 Likes

#12

I afraid, that it is not important, because problem exist in Tutorial Projects(without changes). And answer for your questions is second

0 Likes

#13

Have you tried 1.2.124?

0 Likes

#14

Ah, ok. Please install and try 1.2.124 instead. Instructions: Downloading old version of the editor

0 Likes

#15

This solution don’t give result. I did error in code, build and didn’t saw error, but when I repair code back - building was success

0 Likes

#16

No result. May be I can clean some folders? But I already did it in AppData, again without result :frowning:

0 Likes

#17

I found interesting moment. Build for Windows have very-very big speed, but in HTML5 all is good

0 Likes

#18

As @Johan_Beck-Noren mentioned, it sounds like the “speed” issue comes from a driver update regarding the vsync being disabled. You can check your graphics driver options for that.
Also, have you tried enabling “variable dt” in the project settings? Open game.project, and check the box named “Variable Dt” under “Display”

0 Likes

#19

Thanks, it give result. But anyway - I have problem with opening from “View”

0 Likes

#20

So, the console and curve editor doesn’t work in 1.2.124 either? Would you mind recording a video/gif and/or share a screenshot?

0 Likes

#21

It is my last message for today(limit)

UPD : I simple clean registry - and all good :slight_smile:

1 Like

#22

It looks like you resized the bottom panel to be completely collapsed. The bars at the edges of panels that you use to resize them are the same color as the editor background, so it’s very hard to tell. The editor opens with the default layout but immediately resizes them to how you had them last.

editor_2_collapsed_bottom_panel

It’s very nice to be able to collapse it all the way in my opinion, but it would be better if there was some sort of drag handle graphic so you could actually see the bar. :slight_smile:

The “Show Console”, “Show Curve Editor”, etc. options don’t actually show/hide them, they just switch the tab in the bottom panel.

6 Likes