Admob extension failed building (DEF-3657)SOLVED


#1

Hi, when i try to bundle my app for android i get this error : https://puu.sh/C69c5/87f0e813df.png and I have no idea how to fix it.


#2

The error message tells you that you have two adUnitIdspecified in your xml files.

Which extension are you using (there are at least two AdMob extensions)


#3

this one https://www.defold.com/community/projects/93085/


#4

There is resource bundling issue, I will check it when I get to a computer this evening.
How are you including the extension? As a dependency or copying the directory into your project? In either case, please try the other option.


#5

Where is another one?


#6

I get the error in either case.


#7

Seems like there is still an issue with Defold and resources. The error doesn’t happen on macOS, but only on Windows.

@sven @Mathias_Westerdahl any input on that? Thanks.


#8

Well, no input other than that I thought it was working ok by now, but I’m happy to look into it. Do you have a repro case, or is it enough to create an empty project, add your AdMob extension to the dependencies, and then build for android?


#9

I’ve asked a friend to reproduce the case and he was able to do it with those instructions, granted you fetch the libraries before building.


#10

I got it to work without issues after removing the .jar files included with the Defold engine.

From the AdMob extension docs:
" Again, download it and put it into your project directory. Scroll down to native_extension -> App Manifest and select /game.appmanifest ."

@steags.inc Can you confirm you’ve performed this step?


#11

I think he is referring to https://github.com/defold/extension-admob


#12

yep


#13

I added ticket DEF-3657 for this.


#14

So, I’ve solved it !

looking for new lead I looked a the github of the other extension ( https://github.com/defold/extension-admob ) and found this line https://puu.sh/C9TzW/f938cab6c8.png
I did it, and it worked so yay

either way thank you for your help