AdMob Extension error

#1

Hello, I’m using AdMob Extension with https://github.com/defold/extension-admob/archive/master.zip
When I bundle Android app, Defold shows errors as below. In the screen shot “skipping incompatible … libauth.a …” this is the reason. I’m using macOS Mojave 10.14.4, Defold 1.2.163, Android SDK Platform 28.

2 Likes

#2

Hi @andy6!
Sorry for the inconvenience.
What version of the admob-extension are you using?

1 Like

#3

Hi Mathias, no problem. I just added “https://github.com/defold/extension-admob/archive/master.zip” to Dependencies and fetched the library. When I run my game in testing session, Defold tells the global accessing ‘admob’ is nil. So I tried to bundle Android app then I got the error messages during compile.

0 Likes

#4

Defold Admob extension is an example project that is not production ready for now. Please use https://github.com/Lerg/extension-admob instead

2 Likes

#5

Thanks. I have another problem as below.

  1. I already tried it too. Since I’ve updated Defold and Xcode, I’ve tried Lerg’s version again and compiling with Lerg works well. Bundling Android app is successful. I installed my game on my real device and touched it, then my app shows a screen as below for a second and gets crashed right after. The phone is Samsung Galaxy S8 active(SM-G892A), Android version 8.0.0, Kernel 4.4.78-13220380.

  2. I removed Lerg’s extension from dependencies and bundled Android app again, installed it on my real device, then the app shows below screen and it doesn’t get crashed and works well.

0 Likes

#6

What does your log from the android say?

Let’s ping @sergey.lerg to see if he has any insight?

0 Likes

#7

I captured a chunk though, the log is pretty long as below attached file. It seems there is a problem to use Chrome webview controller. Good idea to let him know.

log.txt (60.7 KB)

0 Likes

#8

I’m testing the bundle builded today with Defold 1.2.163 and admob extesion by Lerg, works ok on both my devices with Android 9 and Androd 4.2.2

5 Likes

#9

Thx for the info! I can sleep a bit easier tonight :slight_smile:

8 Likes