PlayFab Defold SDK Error (DEF-3789)

ERROR:SCRIPT: HTTP request to '' failed (http result: -1  socket result: -5)

I got that message from console after update the latest version on Defold (I click update available link recently, and this what I got after that)
I see this bug, or maybe my setting is wrong?


Does the URL work in the browser? I don’t have access to the code right now so I can’t check the -5 error.


Yea, its just nothing, white screen only


Nothing new :slight_smile:

This error stable on Windows PC. In my game Playfab works on HTML5, Android, MacOS, iOS but “-5 error” on PC.


I’ll create a ticket to investigate this when I get back to the office on Monday


After I try to switch project between Mac and Windows to use defold for PlayFab, I agree with @Dragosha that this issue happend only on Windows.


Can you provide me with the url that fails so that I can try it here?


Ok, its sent to your PM


this has a solution? I have the same error


I must admit that I forgot to investigate this further. Create DEF-3789.




Hi, any news with the problem? need to use playfab, and I have 3 months left. thanks


It’s in our current sprint (started Monday and lasting two weeks). The task hasn’t been looked at yet but will get picked up next week.


Great job :slight_smile:


Could you please change timeout for http request in game.project or in playfabhttps_defold.lua http request?


after added timeout to http.request options an error has changed to

WARNING:DLIB: Unhandled ssl status code: -261
ERROR:SCRIPT: HTTP request to '' failed (http result: -1  socket result: -1000)

SSL handshake failed (-1) for certain https hosts (DEF-2633) (SOLVED)

We (@AGulev and @vilse) are investigating this. The problem is that this is far from 100% reproducible on the Windows machines and network we have available. It’s some kind of SSL handshake problem most likely.