Dmengine.exe has stopped working. Exception code: c0000005

#1

Hello.

I’m trying to build and launch any project and I’m getting same error on 3 projects I tried.
Yes I tried making a project via dashboard.
Anti-virus ON/OFF , Run As Admin, short Path to defold (“C:\Defold”)
I have updated even graphical drivers to exclude some old drivers, no change.

" Project -> Build and Launch " / " Rebuild and launch "
always the same error.
However somehow after recent Defold update I can " Build HTML and Launch " but thats not satisfying the Console is not working…

I have pasted full info from the error window I could get:


Problem signature:
Problem Event Name: APPCRASH
Application Name: dmengine.exe
Application Version: 0.0.0.0
Application Timestamp: 58a1a04d
Fault Module Name: dmengine.exe
Fault Module Version: 0.0.0.0
Fault Module Timestamp: 58a1a04d
Exception Code: c0000005
Exception Offset: 0025d60f
OS Version: 6.1.7601.2.1.0.256.48

Locale ID: 1045
Additional Information 1: 0a9e
Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
Additional Information 3: 0a9e
Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

Read our privacy statement online:
http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0409

If the online privacy statement is not available, please read our privacy statement offline:
C:\Windows\system32\en-US\erofflps.txt


System spec:
Windows 7 Professional
CPU: Inter i7-3770
RAM : 16GB
64-bit Operating System
GPU: ATI Radeon R9 280X (Gigabyte)
Motherboard: GA- Z77-D3H (Gigabyte)

0 Likes

"dmegine.exe has stopped working" for building on a specific computer (Solved)
#2

Hmm, that’s unfortunate. There should be a file named _crash under %APPDATA%\Defold after the engine has crashed, perhaps you can attach it to your post, and we can have a look at it tomorrow?

Also, in the HTML5 build, you mention you don’t see output (in the editor?).
The output is shown in the in the developer console of your browser (I think it’s shown by pressing F12 in both Internet Explorer and Edge)

1 Like

#3

hello,

thank you for your response.
Let’s leave the HTML5 build behind.
The game we need to make for our course is an Android project so let’s focus on that “Build and Launch” / “Rebuild and launch”

Here is the file you mentioned I hope it will help. (I made a *.zip of it cause the forum rules do not allow files with no extensions)

_crash.zip (953 Bytes)

2 Likes

#4

Unfortunately, the _crash file didn’t help me in this case :confused:
Perhaps you can tell me a bit more in detail about the issue. You mention you’ve created a project via dashboard? I guess is was just a simple empty project?

If you bundle the project for Windows, will it launch if you double click on that .exe?

If not, perhaps you could check if there are some dependency (dll) issues for that executable with Dependency Walker. Simply open the tool, and drag in the executable there and it should show if there are any dll’s missing on your system (if any).

1 Like

#5

I have tried 4 projects:

  1. the tutorial thats made by default when we make account on dashboard.
  2. a simple project my friend invited me (this is the project he had by default) on the account.
  3. project made by my friend (he added me to the team) this the project we work on now.
  4. project (blank) just made it while writing this for test prupose.

All those give the same problem. No matter what I do when I click “Build and Launch” / “Rebuild and launch” I’m getting same exception: c0000005

Yes I tried to do Bunlde -> Windows - debugging gives same error.
Bundle -> Windows Application - Release mode - ALL is working fine.
So we know that the realease (non debugging) can be made and it will work (in this case on windows).

So how do we fix the “build” or “rebuild” ??
We both know I cannot work on our game if I can’t see whats happening inside when Im adding stuff.

0 Likes

#6

Well, it’s a tough one.

Do you happen to know the last time it worked? Or perhaps a version number?

You could try downloading an older editor: using the pattern (from here).

http://d.defold.com/archive/%SHA1%/stable/editor/Defold-win32.win32.x86.zip (You find the sha1’s here) using the sha1 of the latest version that you knew worked.

E.g.
1.2.96
http://d.defold.com/archive/0060183cce2e29dbd09c85ece83cbb72068ee050/stable/editor/Defold-win32.win32.x86.zip

1.2.95
http://d.defold.com/archive/7ca47a7f7aa0e4809e31ab2274fd1693a1fc5a7e/stable/editor/Defold-win32.win32.x86.zip

1.2.94
http://d.defold.com/archive/a9ec217c3e4b486c07a86c935b0cc805b6680480/stable/editor/Defold-win32.win32.x86.zip

1 Like