Dmengine 1.2.93 crash (DEF-2331) (SOLVED)

Hello! I’m new in Defold, and cant build my first app (Getting started tutorial), because dmengine crashes (black screen for few seconds, then window closes).
I’m using ubuntu 14.04, dmengine 1.2.93, Java 1.8.0_05 (don’t know what is it, read this string in about).
Turned off IPv6 - isn’t help.
Hope, you can help me

Any log informarion maybe? Check the errors section in bottom part of defold edtor. Perhaps you miss some libs. I’m not sure it is possible to help you telepathically

Hello! I’m sorry to hear that. There should be a crash log stored under ~/.defold… named .crash, could you try to find it and post it here for me to analyze? It would also be good if you could check your version of OpenGL to make sure your drivers are updated.

Console logs:
INFO:ENGINE: Initialised sound device ‘default’

INFO:DLIB: SSDP: Started on address
INFO:DLIB: SSDP: Started on address
INFO:CRASH: Successfully wrote Crashdump to file: /home/dolfero/.Defold/_crash

Nothin in ERROR log (964 Bytes)

Here is my crash file. thnx.

OpenGL version string: 3.0 Mesa 11.2.0

Ah, this is a problem with Linux where an input device is incorrectly identified as a gamepad with a massive amount of buttons, axes and hats. It’s been around for a while and we’ve even had a suggestion for a patch a couple of weeks ago. I’ll fix the issue right away since it obviously affects several people, but the fix will be delayed at least two weeks, not sure how the release schedule looks like for Christmas.

In the meantime, the last time this was discussed someone figured out that unregistering the second device would solve the problem during development.


looks like this problem is with standard drivers for usb inputs, since everyone just have this.

here is the topic that covered the problem and workaround in depth Engine crashes with USB Bluetooth Mouse & Keyboard plugged in (DEF-1992) (SOLVED)

1 Like

The problem has been given issue number DEF-2331 and the fix will be available through the alpha channel later today. It is planned to be released in 1.2.95.


It’s really this problem. If I turn off my usb-mouse, then all working good

@timmakillrot, @nikitaosyak: Could either of you check to see if the problem still persists in the alpha version available at, or if it has been fixed.



Unfortunately, it still doesnt work with my usb mouse included

I have little opportunity to check this at the moment, but as soon as I can, I will report results.

DEF-2331 was fixed in Defold 1.2.96: Defold 1.2.96 has been released

1 Like

still doesnt work in new alpha =(

Would you mind trying the stable release?