Defold 1.2.141 has been released


#41

let me help @lazy.kokos to assemble the whole story here.

Here’s his question in the chat:

got the build completed successfully, when linked against static library. it’s ok on its’ own but we have another issue with static lib itself (its’ the question to library devs, not to you).
So we tried also to build with dynamic library version, which is newer and doesn’t have the issue - and in this case plist version doesn’t seem to help - we’re getting “embedded dylibs/frameworks are only supported on iOS 8.0 and later” despite the version in plist was set to 10.0

My understanding is that @lazy.kokos is trying to build an empty/dummy project with a single native extension that utilises a third party library that was built/linked for iOS 8. The issue they’re having is that they cannot make the whole project get linked for iOS 8.

So probably the question is: how can they ensure that Defold builds/links the project for iOS8 so their 3rd party library is compatible.


#42

First, read this clarification
Basically, it’s currently for Android, to control the flag “-Wl,dynamic”

We currently build for min iOS version 6.0.
There currently is no way of changing that by the user.


#43

Hi, @Mathias_Westerdahl
Would you please explain How to link against dynamicLib concretely?


#44

We currently don’t support linking to the users’s dynamic libraries. It’s in ticket DEF-2732, which we hope to be able to start soon, in the beginning of 2019.