Could not find gl function "glGenPrograms" (SOLVED)

Describe the bug (REQUIRED)
Every time i try to run the project build, my console box says the message below:

To Reproduce (REQUIRED)
Steps to reproduce the behavior:

  1. Open any project (i even tried those samples for testing)
  2. Press (Ctrl+B) or (Ctrl+Shift+B)
  3. The Build open and then close
  4. then those message appear at Console Box

Expected behaviour (REQUIRED)
The build should open and keep showing a black screen (since i haven’t programmed nothing)

Defold version (REQUIRED):

  • Version [1.2.191]

Minimal repro case project (OPTIONAL):
Basecly any project that i try to open

Additional context (OPTIONAL):
So, i searched and i believe that it’s something abt my graphic card.
recently i changed my laptop, i moved the HD from one to another.
but each laptop have diferents graphic cards.

Other thing is that i may installed a bad version of Windows 10.

if someone know how to fix this without format my pc, i would be grateful

Yes, it’s likely that it is a driver issue. What kind of graphics card do you have? After the drivers up to date?

i have an Intel Processator


There is an app it Intel website that seems to update all the missing drivers, i installed and run it, but the error keeps appearing

Ah, I see, you have an integrated Intel GPU. Could you please try the 1.2.192 Beta:

1 Like

Thank you man, it actually worked!!

the build is running perfectly


Good to hear! The fix was contributed by @aglitchman for this release!