Windows Bundle is only 13Mb and not working (SOLVED)

#1

I create release/debug bundle for Windows and it weights only 13Mb, while should use a ton of images. Just checked a few cases like that on forums and not sure where’s mine.

Fixed custom resources syntax to “data/,data2/” and generated a manifest. No build errors. Still same problem and 13Mb bundle.

Sometimes it shows errors like:
C:\Defold Projects…\build\x86-win32\dmengine.exe (System can’t find specified path)
or
C:\Defold Projects…\build\x86-win32\dmengine.exe (Access denied)
or
An error occurred while building Native Extensions, but the server provided no information.

0 Likes

#2

It’s difficult to pinpoint your exact issue. This error seems like it’s a build error, does it mention anything else?

Could you provide a minimal example project that exposes this issue?

0 Likes

#4

Oh, got it! It only includes my bootstrap collection and ignores others. A bootstrap is a controller that loads and unloads collections. Just switched to main and it worked (kind of).

How do I include other collections? O_o

0 Likes

#5

The build relies on a “dependency tree”, where the top node is the main collection you choose.
Then, all those resources that are references from one file to another, are included.
So, simply add the proper collections directly, or refer to them usingn collection proxys and they’ll end up in the build.

Some exceptions: “custom resources” are included as-is inside the archive, so are “bundle resources”.
Then, you also have an option to “exclude resources”, if you’re using the Live Update feature.

1 Like

#6

They are refered as a collection proxys in contoller collection. O_o

image

0 Likes

#7

Just switched to main and it worked

What is in main?

Also are all your collections named properly? Besides the file name there is also another name that you have to set if you press on the root of the collection file.

1 Like

#8

Oh… just saw that all my collections are marked as “Exclude”. Not sure why I even checked these.

Thanks! I’m just so dumb sometimes. Sry. =)

4 Likes