Problem with pulling changes (SOLVED)


#1

I’ve had trouble pulling changes for a while now. I’ve been waiting to post, hoping that either the issue would go away with an update, I’ll figure it out myself or I’ll find someone with similar troubles posting here. I was considering posting this in the bug report section, but I find it more likely there’s a problem on my end.

I work on the project on two computers (at home and at work), so moving the changes from one to the other is the extent of my use of the synchronize function.

What happens is that whenever I make changes and synchronize, I get the window with the “pull” button and after pressing it I always get only the “Done!” message and the option to go ahead with push. Push works perfectly fine - I get to choose to stage any of the changed files and done.

When I try to pull the changes on the other computer, nothing happens. However, if I delete the project folder and choose “import project” on startup, the latest version gets downloaded. I’ve been using this workaround, but there has to be something I’m overlooking that’s preventing me from pulling changes directly.

I don’t remember messing around with any relevant settings (as a matter of fact, I can’t seem to find any relevant settings in the editor) and can’t think of anything else I could do to pinpoint the problem.


#2

Hmm, I haven’t heard of anyone having problems pulling changes. Are you also using an external git client that could perhaps interfere? @mats.gisselson and @Erik_Angelin?


#3

Do you have yet another computer to try from? Are there any other team members, and if so do they have the same problem? Could you invite one of us so we can check if there is anything project specific going on?


#4

Huh, so this probably does belong in the bug section… it’s not everyday I manage to break something in a unique way =P

No external git client, I’m happy to only use the built-in synchronize function.

I’ll see about trying another computer tomorrow.
Nobody but me touched the project so far, though I’d be happy to invite you if it can help. It seems I need your email address do do that, though.

It just occurred to me I could try creating a new project and try to sync that. I have tried deleting Defold and installing it again from scratch, but that didn’t help, so I should see if it is project specific issue.

All of that will have to wait until tomorrow, though. Right now I’m barely keeping my eyes open. Thanks for the replies!


#5

Yeah, please try and sync another project. Which OS are you using? Which location on disk for the project? Any special characters in the path or project name?

You can invite me: bjorn.ritzl@king.com


#6

Changing the project path seems to have done the trick!

I’m using Windows 10 on both machines and the project was saved to the default path (C:\users[username]). There are no weird characters in the username on either computer, but it could be Windows were just overprotective. I did check whether the folder isn’t copy protected yesterday (it was, but removing the flag didn’t help) and I tried running Defold as admin, but neither of these worked.

Now I moved it to just C:\ and successfully pulled synced changes between two work computers. I’ll confirm that that’s what it was when I get home, but hopefully that was indeed the issue.

Edit - a few more thoughts:

I think I forgot to mention that syncing used to work correctly for me, though I’m not sure exactly when it stopped, as I wasn’t using Defold that often at that time. It seems to suggest that a particular Defold and/or Windows update is to blame. The issue was happening in both directions, that is to say, affected two different computers at (as far as I know) the same time, so it doesn’t seem to be the result of other changes I may have done on either machine.

It also seems strange that I’m the only one hit by it, if it’s indeed the result of using the default project path. Once I confirm it was the case, I’ll try a couple more things to see if I can shed some more light on the issue.


#7

Could it be some anti-virus software that is preventing files from being changed?


#8

I don’t think so. I’m only using Windows Defender at home.


#9

All right! I’ve synced with no issue now that I’ve moved the project to a different path from the default.

Thanks for your help!