Problem with new version of Spine. json format changed (DEF-1998) (SOLVED)


#4

Can you open your file (created by the Spine 3.3.07) in the older version (Spine 3.2.01) ?

No, I can’t

Did this happen when simply saving the file from one version (3.2.x) to another (3.3.x)?

Yes, just re-save old project in new version.

At what version did this happen?

Spine 3.3.07

Or have you started using any of the 3.0 features?

We use latest spine. But my animator told that he don’t use any new features, just new version of animation tool for working without some bugs.


#5

We have a list of 3.x features that have been requested, that we’ll work on after this summer.

Can you share this list (I want show list of unsupported features to my animator) ?


#6

Currently, all version 3.x specific features are unsupported. (Apart from the tiny workaround with supporting “weightedmesh”)

As for Spine 2.x features, there is some documentation here:


and here:


#7

Thanks, I just now saw :

Defold supports mesh animation but only with bones, meaning that you can’t animate single vertices. If you need to animate single vertices you can do that through a bone being 100% bound to that vertex only and animate the bone.

It’s realy sad.
Much more work for my animator than I thought :unamused:
Maybe you know when it is planned to fix it?


#8

The current stance is that we will not support vertex animation at all. There are many reasons behind this decision and I made a comment about it a while back. The strongest reason is that vertex animations scale terribly as the meshes grows in size, which makes it a dangerous feature although it can be convenient for some animators of course. If you could give an example where the workload for animators increases significantly because of this restriction it would help a lot.


#9

My animator show me example from his games:
a lot of vertex animation:

here’s mouth:

And one more example from spine forum: http://ru.esotericsoftware.com/forum/viewtopic.php?p=14870


#10

That’s a great looking animation!! :open_mouth: I’ll try to give it some thought, but as it looks now we simply can’t animate individual vertices on the cpu and have that scale in perf in any reasonable way. Right now some ideas are floating around in my head where this would be a checkbox for really heavy-duty things (like the house-monster), where we would at build-time burn out all vertices into a sequence of meshes (flip-book but for meshes rather than textures) and then lerp between meshes on the gpu to use the result as bind-pose. No idea how that would work or perform really, but could be an option. Sometimes absolute brute-force can work quite well, especially if you can do a lot of the calculations at build-time. :slight_smile:
What we really want to avoid is that animators spend a lot of time making all these great animations by moving vertices, and then there is no way to have that run with everything else in the game on the target platform. That makes everyone really sad. :wink:


#11

Thank you for such a detailed response. :thumbsup:


#12

This has been fixed in 1.2.87: Defold 1.2.87 has been released


#13

Bug still reproduce.
Exported from spine json with “mesh” doesn’t work. And works good after renamed all “mesh” to “weightedmesh”


#14

Oh, weird. @sven any input on this?


#15

I’ll check with the Blossom team tomorrow, but they had the same problem and we used their content to verify that it has been resolved.


#16

Hello @AGulev and thanks for the ping, I have to admit that I forgot about this after I wrote the initial answer to you. I’ve checked with Blossom Blast Saga who also experienced this problem but they are now able to export using Spine 3.3.x. There are however new features in Spine 3.3.x which are not supported, could it be that you’re using any of those?


#17

I don’t know (
I have no spine and all animations made by my animator. I can send you in Slack or email full project with exoprt one of my animation before renaming “mesh” in export file.


#18

I think it’s time to include @Mathias_Westerdahl and/or @Ragnar_Svensson in this discussion. They could probably tell you more about which features of Spine 3 that we don’t support and how to work around it.


#19

I have no problem with it renaming of all “mesh” to “weightedmesh” solved my problem.

But As I understand it’s the same problem like PSA: Spine 3.0.12 introduces a bug with Defold (DEF-1655) (SOLVED) when format of spine export was changed.


#20

Yes, the only 3.x feature we support, is their renaming of skinnedmesh, to weightedmesh to mesh, so that you can at least open older animations.

As for what we don’t support, no we don’t have a clear list. I know two of two new things that are unsupported: shear matrices, and linked meshes. But, other than that, simply all new features from 3.0 and forward, we don’t support.

Recently, one of our artists happened to get affected by this, since they exported the file from a newer spine editor. The advice then was to reexport it in an older version 2.x, and compare the files to see what feature is actually afffected.

“I have no problem with it renaming of all “mesh” to “weightedmesh” solved my problem.”

The editor does this automatically for you now. Is it still a problem for you?


#21

Just checked, yes. Editor do not do this automatically.


#22

Hmm, good clue @AGulev!

Looking at the code now, and we found an issue that made it work for a later version of Spine (3.4.02) and onwards, but we intended to fix it for some earlier versions too. This won’t be fixed in the 1.2.90 release though, but hopefully the next one after that. In the meantime, your artist might try to export the files from a that specific Spine version.


#23

Solved in 1.2.91