PlayFab Defold SDK Error (DEF-3789)

#1
ERROR:SCRIPT: HTTP request to 'https://xxxx.playfabapi.com/Client/LoginWithCustomID?sdk=DefoldSdk_0.44.181001' failed (http result: -1  socket result: -5)

I got that message from console after update the latest version on Defold (I click update available link recently, and this what I got after that)
I see this bug, or maybe my setting is wrong?

0 Likes

Database and chat for a game?
#2

Does the URL work in the browser? I don’t have access to the code right now so I can’t check the -5 error.

0 Likes

#3

Yea, its just nothing, white screen only

0 Likes

#4

Nothing new :slight_smile:

This error stable on Windows PC. In my game Playfab works on HTML5, Android, MacOS, iOS but “-5 error” on PC.

1 Like

#5

I’ll create a ticket to investigate this when I get back to the office on Monday

0 Likes

#6

After I try to switch project between Mac and Windows to use defold for PlayFab, I agree with @Dragosha that this issue happend only on Windows.

1 Like

#7

Can you provide me with the url that fails so that I can try it here?

0 Likes

#8

Ok, its sent to your PM

0 Likes

#9

this has a solution? I have the same error

0 Likes

#10

I must admit that I forgot to investigate this further. Create DEF-3789.

0 Likes

#11

thanks

0 Likes

#12

Hi, any news with the problem? need to use playfab, and I have 3 months left. thanks

1 Like

#13

It’s in our current sprint (started Monday and lasting two weeks). The task hasn’t been looked at yet but will get picked up next week.

1 Like

#14

Great job :slight_smile:

0 Likes

#15

Could you please change timeout for http request in game.project or in playfabhttps_defold.lua http request?

0 Likes

#16

after added timeout to http.request options an error has changed to

WARNING:DLIB: Unhandled ssl status code: -261
ERROR:SCRIPT: HTTP request to 'https://XXXX.playfabapi.com/Client/LoginWithCustomID?sdk=DefoldSdk_0.52.190304' failed (http result: -1  socket result: -1000)
1 Like

SSL handshake failed (-1) for certain https hosts (DEF-2633) (SOLVED)
#17

We (@AGulev and @vilse) are investigating this. The problem is that this is far from 100% reproducible on the Windows machines and network we have available. It’s some kind of SSL handshake problem most likely.

1 Like

#18

Do we have any news about this?
Just picked up Playfab again for our next game and my collegues in office with Windows experience the same problem. I have verified with my Windows computer from home and getting the same error. MacOSX works just fine.

WARNING:DLIB: Unhandled ssl status code: -261
ERROR:SCRIPT: HTTP request to 'https://****.playfabapi.com//Client/LoginWithCustomID' failed (http result: -1  socket result: -1000)
0 Likes

#19

No news. But we are planning a new sprint on Monday and will take another look then.

0 Likes

#20

I have this problem too.

In windows 7 with cable works

in windows 10 with cable works in my home , in other routers does work.
in windows 10 with wifi doesnt work

0 Likes