Multitouch issues (DEF-3685) (SOLVED)


#1

I am trying to use multitouch input on an Android device. I experience two kinds of problems for fast touches.

  1. Sometimes the engine does not send the released event; so I get two pressed events with the same id.

  2. Sometimes the engine keeps calling on_input with action_id = touch_multi but with pressed = false and released = false. As if a touch is going on while there is no touch at all. Once this starts never stops.

I see both issues on a debug build via adb on a huawei P10 lite.

Any help? Thanks!


#2

Huh, we used to have issues like those you describe but they were fixed quite some time ago. Apparently there’s still a problem on certain devices. @sven was the one who made the fix. We’ll have to take another look next week when everyone’s back. Sorry about that.


#3

Thanks! And thanks for the great work with Defold!

Happy New Year!


#4

Created DEF-3685 and included it in our sprint planning today.


#5

I am facing this problem too in my game.


#6

It’s in our current sprint and @AGulev has managed to reproduce it.


#7

Solved in 1.2.145