Launching New Local Engine failed in Russia


#1

Instead of starting (ctrl + b) an error “Launching New Local Engine failed:
java.net.ConnectException: Connection refused: connect”
This alert shows when i’m using timer (native extension)
When i build html version shows this
“An error occerred while building Native Extensions, but the server provided no information”
version 1.2.127 (in the previous version worked without errors)

Without a timer, everything runs without errors, but the timer is very necessary (
ps I can not use the timer.lua, because timer need in gui script

Thanks!


#2

Hi @alexandr.gil!

The most recent log files for the extension server shows us that there was a timeout error (30seconds), could this be related to your build? Is the internet connection perhaps a bit flaky?

What happens when you try again?


#3

I try for two days and get the same error (
I found a solution.
I can not load this forum (forum.defold.com).
I put the VPN and I was able to compile the game without errors
Perhaps the IP addresses that are responsible for the forum.defold.com and the native extensions are blocked in my country (I am from Russia)
Thanks! :slight_smile:


#4

Ah, I heard something mentioned by @Oleg_The_Evangelist about IP bans that were affecting access from multiple online services from Russia.


#5

folks at the Russian Telegram community (https://t.me/DefoldEngine) tell they get random results with Defold services, depending on their region/provider. Forum and the build server currently seem to require VPN.

The Ru community tried to negotiate with PKH to whitelist our pool of IP addresses, but got no response. So, guess, VPN it is for Ru users currently.