I can't edit property fields for a Monarch screen_proxy.script (SOLVED)

#1

I’m trying to use the Monarch library. I’m referencing tweetFighter as an example. But when I tried to add a script instance to screen objects in the controller, I get a white instance, not the ‘magic’ blue instance that lets me edit properties in the script. (I’m adding instances of "screen_proxy.script’ as it seems that the “screen.script” instances in tweetFigter have been deprecated.

Regardless, I can’t edit the script’s fields in the editor. Help!

TweetFighter’s setup:

0 Likes

#2

The white instance should turn blue as soon as you change any properties from the default ones.

1 Like

#3

Thanks. That helps more than you might guess. Was pulling hair out (googling for the last hour).

Tried a few things … it’s not working yet. I can instance a Monarch “screen.script” and edit the fields, but I can’t edit the fields in an instance of a Monarch “screen_proxy.script”.

you’ll need to expand the image, to see my situation

1 Like

#4

I found the problem. I had to widen the edit pane to reach the field boxes. Whew!

2 Likes