Crash while adding game object to collection (SOLVED)

#1

Howdy! I’m having a rather peculiar bug. I’m working from a blank project, and wanted to add a game object to my main collection. When I click the “Add Game Object” item in the popup menu, Defold crashes. It’s kind of frustrating, hahaha. Thanks in advance for your help! Hopefully it’s a configuration error or something.

To Reproduce:

  1. Go to Main.collection
  2. Right click the Collection list item on the right.
  3. Click “Add Game Object” from the drop down.
  4. Editor crashes.

Expected Behavior:
I believe a dialog box to create a game object should appear? I am not sure though.

Defold Version:
Defold Editor 2.0 v.1.2.145

It’s specifically happening at this point:

Platform:
I am using
OS: Windows 10 Home 64-bit
CPU: AMD Ryzen 5 2600
RAM: 64GB 3200MHz DDR4
Graphics: Radeon RX 580

I tried uploading the error log, but it seems to have exceeded this box’s character limit.

0 Likes

#2

The way how we work with Defold versions is pretty different that people used to see.
We deliver the new engine version every two weeks, and the new editor version when a feature or a bug fix is done.
That means if you don’t update you editor, we can’t provide you support or guarantee stable work.

Moreover, we usually cut off supports of old Defold SDK versions on our build servers, that means if you don’t update Defold, one day you will become in a situation when you can’t build the game.

The current version of the engine and the editor is 1.2.159, on next week we release 1.2.160. Please, update Defold and check your issue again, I believe everything should be fine with the latest version.

2 Likes

#3

That indeed fixed the problem, thanks! I had no idea I was out of date.

1 Like