Build in 1.2.164 not showing anything until I resize

#1

Recently updated to 1.2.164 and found that my build was not working with no errors in “Console” or in “Build Errors”…
First thing I tried is to remove the build folder, but that did not help.
Then I realized that the build DID in fact work, but my game was just not showing. When I resize the window the game magically appears :slight_smile:
Seems like the first render just never happens?

Defold 1.2.164
Macos 10.14 (18A391)

0 Likes

#2

Can you reproduce this in any project or just the one? Can you share a minimal version of a project where this happens and share it with me (bjorn@defold.com)?

0 Likes

#3

I remember having the same issue on Mojave dark theme after setting NSRequiresAquaSystemAppearance = NO in Info.plist (which is no longer needed due to linking against a newer macOS SDK).

This was my original issue, but I can no longer reproduce it on Catalina: Defold games show blank screen in Dark Mode

My workaround was to resize the window on boot with defos:

if system_name == "Darwin" then
  local x, y, w, h = defos.get_view_size()
  defos.set_view_size(x, y, w, h - 1)
  timer.delay(0.0, false, function ()
    defos.set_view_size(x, y, w, h)
  end)
end
0 Likes

#4

I can reproduce this on any project, even when I create a new empty project from the template tab. I’ll send you the project, but is is basically just a new empty project :slight_smile:.

@dapetcu21 mentioned this could be related to the macos dark theme, but setting macos to use the light theme, the project just shows a white window until I resize it…

1 Like

#5

@dapetcu21, I did not change NSRequiresAquaSystemAppearance and setting light mode does not seem to help.

Your workaround works perfectly for now :+1:, thx!

0 Likes

#6

I’m unfortunately unable to reproduce this. Are you using any software for screen recording, taking screenshots, or in other ways interacting with the opened windows?

1 Like